Overview
While attempting to send emails to the external, not Kerio Connect domains, the message is being returned with the following entries in the Mail logs:
Result: failed, Status: 5.4.0 550-PTR (rrcs-1-1-1-1.central.domain.com) rejected: 550 Please use a non-generic PTR
Diagnosis
Many mail servers check PTR records against a set of regular expressions to see if it matches a generic PTR such as "1-2-3-4-dynamic-ip.example.com" or "11-22-33-44-host.hostingcompany.com". Since the vast majority, but by no means all, of email that originates from such addresses is spam, many spam filters refuse email originated from such sources.
To pass the PTR check, you'll have to make sure the IP matches the expected hostname. If your mail server is mail.example.com
, it should look like this when doing host
or dig
:
mail.example.com has IP 1.2.3.4
4.3.2.1.in-addr.arpa domain name pointer mail.example.com
If your mail domain isn't XX.XXX.XXX.XX.static.domainname.com
then you need to change it.
Solution
It's recommended to contact your DNS hosting provider and ISP to create a PTR record on your behalf, as this is not a problem with the Kerio Connect server, but with the domain's DNS settings.
For more information, please refer to Essential DNS Records for Mail Delivery and Spam Protection.