Overview
While configuring custom whitelists to work on top of the Spam Filter, the IP address filtration is not applied.
The IP address group contains the trusted IP address list.
Prerequisites
Access to Kerio Connect Administration
Diagnosis
The whitelist group applies only to check against the internet blacklists section. This is the default behavior of the Spam Filter feature.
Whitelisting can be done by IP in the "Custom whitelist of IP addresses" section, but that only affects the Internet blacklists. You can override the Spam score in the "Custom Rules" tab.
Solution
- Navigate to Configuration > Content Filter > Spam Filter > Custom Rules.
- Add a new custom rule with such settings:
Condition: Mail Header
Header: Received
Type: contains substring
Content: 1.1.1.2
Action: Treat the message as non-spam
Note: replace the content with the necessary IP address value.
Confirmation
Email messages from the listed IP address are no longer blacklisted.