Overview
When trying to share mail account folders such as INBOX and Calendar between 2 domains using Delegation, the access is not granted because of the default Kerio Connect setup. It can be changed by tweaking Public Folders settings and configuring Delegation in Kerio Connect Client or Webmail.
Preconditions
Access to Kerio Connect Administration
Diagnosis
The Kerio Connect uses the different mechanisms for interdomain sharing based on the Public Folders configuration. It is done to meet the security requirement of domain users' not being able to view other domain users' information.
Solution
- Login to Kerio Connect Administration and navigate to Configuration -> Domains -> Public Folders -> set location to Global for all domains.
Note: when changing the sharing between domains, the previously shared folders are no longer available.
- Open Webmail and configure Delegation for the second domain user.
For more information, please refer to Using Delegation in Kerio Connect Client.
Confirmation
The User folder (INBOX, Calendar) is delegated to another domain user and appears in the Shared Folder section.