Overview
When there is a need to change the Full name, surname, or first name in the contact information, it can be done manually from Kerio Connect server-side. You might experience issues like not being able to edit or delete Contacts' information from the Webadmin interface.
There are multiple places where account information is stored, including Contact's tab with First, Middle, and Last Name.
Prerequisites
Administrator access to Kerio Connect server
Diagnosis
The Contact's information is located in multiple directories including Public domain folders, personal Contact, and User configuration files. The directories and files to check are:
<kerio_connect_store>/mail/[domain]/#public/Contacts/#msgs
<kerio_connect_store>/mail/#public/Contacts/#msgs
<kerio_connect_store>/mail/[domain]/[username]/.personal
<kerio_connect_installation>/users.cfg
It might happen the configuration from Webadmin is not being propagated to the server-side causing inconsistency in Contact's details. In such a scenario, the Contact change can be done manually by modifying the necessary files.
Solution
- It's recommended to stop the Kerio Connect service before any modification of the mentioned files.
- Navigate to the #msgs folders and open .eml file. The formatting will include the following variables:
Subject and FN - Full Name
N - Name, in Lastname-Firstname format
- These values reflect the Webadmin user configuration:
- An identical configuration is stored in .personal user files.
- The users.cfg file contains only Fullname information.
- Start the Kerio Connect service.
Confirmation
Contact user details such as Firstname or Surname are being changed successfully.