Overview
While experiencing user folder Performance issues, the contents of the index.fld and status.fld files should be repaired. The process is called the manual repair of users' folders.
It can be achieved by using the indexing (rebuild) utility, linked in the section below. The script uses command-line bash commands.
You may occasionally receive Server errors Root folder cannot be listed or Failed to read rights from folder INBOX, internal error.
Prerequisites
- This process applies to Kerio Connect installed in Linux (deb, rpm) and macOS.
- You need to configure the Full Backup of the Kerio Connect store before proceeding.
Diagnosis
The particular folders became corrupted because of local policies or issues with the data store or server performance.
Solution
Manual Reindexing Process for Linux
-
Download the attached index_status_fld.sh script.
-
Determine whether there is a need to delete the __wm__autoCompleteContacts folder.
If the folder Then Needs to be deleted
Proceed to the next step. Does not need to be deleted Modify the script so that the folder is not deleted and then proceed to the next step.
-
Make the file executable:
chmod +x index_status_fld.sh
. -
Run it as a Root user from the
store/mail/<domain>
directory:./index_status_fld.sh
.
Manual Reindexing Process for macOS
- Download the attached macos_index_status.sh script.
- Install Homebrew dependency:
/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"
- Install the rename package:
brew install rename
- Make the file executable:
chmod +x macos_index_status.sh
- Execute the script from the domain directory, i.e. /usr/local/kerio/mailserver/store/mail/<domain>:
./macos_index_status.sh
Important
The reindexing process may break the secondary calendars. If you have any users with secondary calendars, after performing re-indexing, you will need to manually adjust the status.fld
file to change it back to a calendar using the steps below:
- Stop the server.
- Open the
status.fld
in the relevant folder. - Check the previous
status.fld
(it should be named asstatus.fld.bad
). - Copy over the
T
,W
andY
lines fromstatus.fld.bad
to the newstatus.fld
. Examples of the lines to be copied (the values may be different in your file):- T2
- WIPF.Appointment
- Yspecial1
- Rename/remove the
index.fld
file to reindex the folder again. - Start the server.
Testing
All domain mailboxes are being manually re-indexed.