Overview
At times when renaming a domain in Kerio Connect, the process fails and the following entries are found in the Error log:
[08/Sep/2019 21:56:14] DomainRenameHelper.cpp: Domain Rename: Error in creating store backup
[08/Sep/2019 21:56:15] main.cpp: Rename domain process failed
This article explains why this error occurs and how you can troubleshoot it.
Root Cause
These errors are mainly caused by environmental store issues like long file/folder path for Windows, .journal.db corruption, etc.
Process
-
Rename the domain name directly in the mail store. It creates an alias domain in the store.
-
Log into the Kerio Connect Webadmin and remove the alias for the domain.
-
Rename the domain name in the Webadmin.
-
Restart Kerio Connect. Log into Webadmin and check if the correct domain is created.
-
Stop the Kerio Connect service.
-
Rename the folder that contains all the mails to the new domain name.
An explanation for this step:
When the alias is removed in step 4, it aligns with the right domain, but the store still redirects to the new mail store.
At this point, the renaming is done correctly, but the store is still missing. So you need to check the mailstore and then change the name to the correct domain name. -
Start the Kerio Connect service. The domain name change process is complete.