Overview
When using the full-text search feature, and when the reindexing is stuck, searches cannot be performed. The following error is received:
Server Error: Your full text index is being re-indexed. This operation can take a while.
Environment
Kerio Connect version 9.x.x
Requirements
Access to the server files.
Root Cause
The full-text indexing process is stuck.
Resolution
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Please check for any errors in the following location: web admin GUI > Configuration > Store directory > Full-text search.
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Press on Rebuild Index and check for any error messages.
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If the Rebuild Index is greyed out, please toggle the functions off, then on and leave it to reindex.
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NOTE: This is an operation taking quite some time, as it indexes every email in its integrity, not only the headers.
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If there are still issues after the above, please proceed with the below steps:
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Stop the Kerio Connect service.
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Navigate to the Kerio store folder
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Windows default:
C:\Program Files\Kerio\MailServer\store
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MacOS default:
/usr/local/kerio/mailserver/store
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Linux default:
/opt/kerio/mailserver/store
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Delete or move out of the Kerio folder the fulltext folder.
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Start the Kerio Connect service and allow for the full-text index to be rebuilt from the beginning, avoiding any errors.
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Confirmation
After the full text reindexing is finished (this can be checked at web admin GUI > Configuration > Store directory > Full-text search), the users are able to search.