Overview
Users encounter an error message when trying to connect Kerio Outlook Connector Offline Edition with Outlook 2016. The error message is as follows:
Kerio Outlook Connector
Checking of Connection to Kerio Connect Failed.
Kerio Outlook Connector is not connected to Kerio Connect.
(For technical support: 0x80042004, Unknown error.)
This article provides the root cause, troubleshooting steps, and an alternative course of action in case the steps provided do not resolve the issue.
Root Cause Analysis
Diagnosis
For the error described above, all signs point to Windows update KB2585542. This affected the system library used by Kerio and many other applications.
Solution
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See if the update is installed. If it is, uninstall the update.
- In the Control Panel, go to Programs > Programs and Features.
- Select Installed updates option and look for KB2585542 in the Microsoft Windows section.
- Uninstall the update.
- If the error persists, go to next step.
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Check if any other 3rd-party software is not blocking the Kerio Outlook plugin.
- Antivirus programs and personal firewall programs can change or remove packets, rewrite files on disk or alter the memory of running programs. All of these can cause problems for Outlook. Disable any antivirus programs and personal firewall programs.
- Outlook add-ins (also called "plug-ins") can cause conflicts with the Outlook Connector.
- To disable other Outlook Add-ins:
- In Outlook, go to Tools > Options > Other > Advanced Options. For Outlook 2016 and up: Go to File > Options > Add-ins.
- Click on Add-In Manager. Go to Outlook 2016 > Manage: COM Add-ins > Go button.
- Uncheck everything except for Kerio Outlook Connector User interface, then click OK.
- Exit Outlook, reboot PC and try to connect Kerio Outlook Connector again.
- If the issue is still not fixed, go to the next step.
- In Outlook, go to Tools > Options > Other > Advanced Options. For Outlook 2016 and up: Go to File > Options > Add-ins.
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The Outlook profile is a frequent cause of problems. Many problems can be resolved by creating a new profile.
- Open Control Panel > Mail.
- Open Show Profiles. You will see a list of your current profiles.
- For the When starting Microsoft Office Outlook, use this profile option, select Prompt for a profile to be used.
- Click Add to create a new profile. Follow the steps and create an account of Additional Type, Kerio Connect server.
- Please make sure that you set Default Delivery Location to Kerio Outlook Connector Store. This is critical for Kerio Outlook Connector to function properly.
- Complete the account with the information you have used to create prior Outlook Connector accounts.
- Open Control Panel > Mail.
- Make sure that the Kerio Connect Outlook Connector is the same version as the Kerio Connect server version
- You can find your Kerio Connect server version in the web administration console
- You can find your Kerio Connect Outlook Connector version in the Kerio Connect tab > About
- For instructions on how to upgrade the connector please refer to:
- You can find your Kerio Connect server version in the web administration console
- If this does not resolve the problem, contact Kerio support.
Contacting Kerio Support
If none of the above steps solved your problem, you should contact Kerio Support. Before you contact us, please do the following so we can resolve your problem as quickly as possible.
- Gather KOFF Debug logs.
- Enable SMTP Server, IMAP server, and KOC Offline Requests in the Kerio Connect Webadmin > Logs > Debug log. We will want the debug log after you next experience the problem.
- Gather KOFF installation logs. To do this, start the Command Prompt and type
%temp%
. Look for a file that starts with kerio-connect-koff*. - Send the files above to Kerio support, including details on the exact time, the username that experienced the problem, and the versions of the user's Operating System, Outlook, and Kerio Outlook Connector.
Confirmation
Once the Kerio Outlook Connector is installed, the integration is now completed with Windows. The error for connection failed will no longer occur.