Overview
When POP3 is connected, the Kerio Connect downloads incoming emails from the remote mail server or domain and stores them into individual mailboxes.
Kerio Connect can retrieve messages from remote server mailboxes via POP. A scheduled action issues (initiates) the email retrieval from the host, and the sorting rules process the downloaded messages.
Such configuration involves defining remote mailboxes with POP3 and applying the sorting rules to organize the downloaded messages in Kerio Connect mail server.
Diagnosis
Anti-spam and Antivirus engine features are only applicable to emails received via SMTP (Simple Mail Transfer Protocol) and do not apply to emails retrieved via POP3.
POP3 is used to fetch emails from the mail server, while SMTP is used to deliver them to mailboxes on the internet.
As POP3 is a client-side function, it is recommended to store information received from other mail servers without any modification (as most of the other mail clients do the same).
Note: if you're getting the below POP3 client entry in Debug logs and the Kerio Connect is installed on the Windows server, make sure to apply Microsoft patch for TLS protocols.
{pop3c} Cannot establish SSL session with server remote_server.com:995
Solution
Defining Remote Mailboxes Using POP3
- Log into your Kerio Connect administration interface.
- Go to Configuration > Delivery > POP3 Download.
- In the Accounts section, click Add.
- On the General tab, enter the name of the POP3 server, username, and password of the POP3 account.
Note: The maximum password length allowed is 119 characters.
- Under the Sorting and delivery section, you can:
- Configure the delivery of messages to a specific address.
- Use predefined sorting rules.
- On the Advanced tab, you can:
- Require a secure connection for POP3 download.
- Set download limits per session.
- Set the retention policy.
- Click OK.
Confirmation
The remote mailboxes appear in the POP3 Download tab under the Accounts section.
Applying Sorting Rules
Sorting rules define how Kerio Connect delivers messages downloaded from a remote POP3 mailbox. You can deliver messages to specific users or forward them to a specific email address by following these steps:
- Log into your Kerio Connect administration interface.
- Go to Configuration > Delivery > POP3 Download.
- In the Sorting Rules section, click Add.
- Enter the Sort address. This reference email address is used to sort the messages.
- Enter the Deliver to address or click Select to locate an address from the Kerio Connect server.
Note: This is an external address.
- Click OK.
- Confirmation: The Sorting Rules will appear in the POP3 Download tab under the Sorting Rules section.
Special Sorting Rules
* > admin@example.com
- This rule allows Kerio Connect to deliver all messages that are not complying with any rule to the defined email address above (highlighted in bold). Without this rule, non-compliant messages are discarded.
*@example.com > *@example.com
- This rule allows Kerio Connect to sort messages according to the email addresses and aliases.
Note: Kerio Connect stores the timestamp of fetching messages, not the actual date of receiving the messages by the POP3 server. You can minimize the time difference between the Kerio Connect POP3 server and the remote POP3 server by scheduling the downloading of POP3 emails every minute.