Overview
When configuring the Shared Contacts folder in Webmail, the contacts are not being displayed in Apple's Contacts application. The permissions are set to Everyone Editor or higher (owner).
Domain users cannot view the Shared contacts in the Apple Contacts. Reinstalled profile using the Kerio Connect Account Assistant is not showing Shared Contact List as well.
Prerequisites
Administrator (root) access to the Kerio Connect server
Diagnosis
Shared Contacts folders are not synced automatically by the CardDav protocol as it's a protocol limitation. Apple decommissioned the AddressBook framework, the Contacts framework is now being used. For more information, please refer to the AddressBook developer's guide.
After making a shared folder visible, it can be viewed in Webmail of the other user's mailbox.
The Folders to Sync are showing the Shared Contacts folder only for Exchange protocol, but not for CardDAV.
Only Personal contacts and folders are displayed in the Apple Contacts application. The shared folder is not presented because of the protocol (Exchange) limitation.
Note: if the shared contacts are meant to be shared to all users, convert it to a public folder instead. This way contacts can be synced using CardDAV URLs.
Solution
- Navigate to the Kerio Connect domain folder. Defaults are:
- Windows:
C:\Program Files\Kerio\MailServer\store\mail\<domain>
- Linux:
/opt/kerio/mailserver/store/mail/<domain>
- macOS:
/usr/local/kerio/mailserver/store/mail/<domain>
- Windows:
- Navigate to the user's Contacts folder, i.e.
<username>/test_contacts/#msgs
. Copy the .eml files into the other user's Contacts folder.
- (Alternative option) Log in to Webmail -> Contacts, ctrl-A to select all, hold ctrl button, drag the contacts from the shared folders to "My contacts".
- Re-index the second user's mailbox.
- Close the Apple Contacts app and re-open it again.
Confirmation
Shared Contacts are synced to the other users' Contacts app.