Overview
While importing users from Active Directory to Kerio Connect, the default user account format might be not suitable, e.g. jdoe@domain.com instead of johndoe@domain.com
The default email address, Send-From, Reply-To, Forwarding can be changed from Active Directory User Management and Administrative Center.
Preconditions
Administrator access to Kerio Connect and AD server
Diagnosis
When adding a user from an Active Directory server to Kerio Connect, the email will be generated based on the username followed by the domain name. However, you can change this email by changing the Kerio Connect attribute following the below steps in the Active Directory configuration.
Process
- Login to Active Directory Users and Computers Management console.
- Right-click on the necessary user -> Properties.
- Open Kerio Connect Account tab -> E-mail Addresses.
- Add a new Email address or Edit the existing one. Set a Special Reply-To address if needed.
- The forward email addresses can be configured by selecting Forwarding.
- Storage size, number of messages, and maximum outgoing message size can be applied using the Mailbox Limits option.
- Administration rights, permissions, and user restrictions can be set through Rights and Restriction submenu.
Alternative way
The user parameters can be changed through Attribute Editor:
- Open the Active Directory Administrative Center.
- Click on Domain > Users and right-click on the user you want to edit, then go to Properties.
- Navigate to Account and scroll down to extensions.
- Open the Attribute Editor tab and locate Kerio variables such as kerio-Mail-Address, kerio-Mail-ForwardAddress, etc
- Change or add the value for an email address or other necessary Kerio attributes.
Confirmation
The User parameters have been changed and synchronized to Kerio Connect Administration.