Overview
If your Kerio Connect Commercial or Trial/Evaluation License expired and you want to renew, extend or add more Users, your GFI Sales Partner should be contacted. Until the server host (Windows, macOS, Linux) gets an updated license, the local license key can show outdated or incorrect Software Maintenance information.
There can be delays in the update process due to various reasons, as Product renewals are being processed through different channels, including Partners, Resellers, Distributors, GFI Sales.
Diagnosis
The license is expired blocking the normal work of Kerio Connect. An automatic License update from the Kerio servers reaches the maximum interval (48 hours).
Important: purchase your license upgrade at least two weeks before its expiration date.
For more information, please check the License Expiration in Kerio Connect.
Solution
- Check Spam Folder in your mailbox
- Update Registration Info
- Install License Key file
- Install a Temporary Trial License
- Contact GFI Sales
Check the Spam Folder for Your License
Manually updating your license information depends on having a valid license key code, which should have been provided by your GFI Sales Partner. You may have received it in your Spam/Junk folder.
If you still don't have your license key, please contact your GFI Sales Partner.
Update Registration Info
Note: This process requires that you have obtained a valid license key code and that your Kerio Connect server has a working Internet connection.
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Open the Kerio Connect Administration console.
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Select Dashboard, and click on Update registration info.
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Follow steps 2 and 3 in the Registering Kerio Connect in the Administration Interface.
Note: If you see the error Unable to continue. The security code or license key is not entered correctly, then verify that the server has a working Internet connection with no firewall restrictions for HTTPS traffic on port443
. If the issue persists after ensuring unrestricted HTTPS traffic on port443
, another cause of this error might be the license key having exceeded the download limit. Please, contact support to verify if the download limit has been exceeded.
<supportagent>
AGENT-ONLY NOTE: Another potential root cause of the above error in step 3 is the license key having exceeded the download limit. This can be checked by Identifying the Customer's License Key in KISS and looking at the Download limit field. If the download limit is maxed out or exceeded (for example 10/10 or 11/10), this same error will pop up when the customer tries to update the registration info.
Whenever this happens, direct the customer to Purchasing or Renewing Licences and Resetting Download Limits for Kerio Products.
</supportagent>
Install License Key File
If the above step didn't work, you can manually update the license:
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Open the Kerio Product registration page.
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Enter your license and the captcha code, and click NEXT.
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The next screen displays a summary of the license details. If these details are outdated or incorrect, then proceed to the Contact GFI Sales step. Otherwise, click NEXT.
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Review the registration details, select the checkbox for the Privacy Policy Terms, and click NEXT.
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Choose the correct OS, select the language, and click NEXT.
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The next screen (5/6) shows all of the license details. Click FINISH.
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To download the
license.key
file, click DOWNLOAD THE LICENSE. -
Open the Kerio Connect Administration console.
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Select Dashboard, click on Install License.
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Click Browse, and then select the
Your Kerio Connect server license is now fully registered.license.key
file.
Contact GFI Sales
If the above steps didn't work, please contact GFI Sales directly.
Confirmation
License details are updated and shown correctly in the Kerio Connect Administration.