Overview
Customers may report that when they create a nested Public Contacts folder in KOFF, the contacts are not being synced with the native macOS Contacts application. This article describes the reason for this issue and a possible workaround.
Diagnosis
By default, when a nested Public Contacts folder is created, Outlook stores the data (actual contact cards as .eml files) in the following folder:
<kerio_store>/mail/<domain>/#public/<parent_Contacts_folder>
In this example (Linux), the Sales1 folder is not being synced with the macOS Contacts application, and it is created in the following directory:
/opt/kerio/mailserver/store/mail/<domain>/#public/Sales
- The default directories are:
- Windows -
C:\Program Files\Kerio\MailServer
- macOS -
/usr/local/kerio/mailserver
- Linux -
/opt/kerio/mailserver
- Windows -
- If the public folders are set to Global for all domains, then the path will be different
<kerio_store>/mail/#public/<parent_Contacts_folder>
.
The reason for this issue is that the nested Public Folder cannot be picked up automatically by the Apple Contacts application. The scope of the query is determined by the value of the Depth header. The Apple Contacts depth is just 1. For more information, please refer to RFC6352.
Solution
As a workaround, the Nested folder can be moved to a general public folder.
- Stop the Kerio Connect service (Windows, Linux, and macOS).
- Open the
<kerio_store>/mail/<domain>/#public/Sales
folder (or the corresponding contact folder). - Move the entire nested folder to
<kerio_store>/mail/<domain>/#public
. You can use WinSCP or native SSH client for Linux/macOS.
- Start the Kerio Connect service.
Confirmation
Close the macOS Contacts app, re-open it again, and then wait a couple of minutes for the contacts from the folder to synchronize.