Overview
Kerio Connect can archive the whole server's messages on a local hard drive or to a remote email address. In Kerio Connect 9.1 and newer, you can also archive each domain separately to a remote email address. It's not possible to archive public folders' data.
Users need to have Archive folders administration rights.
Archiving saves messages sent and received by a user after archiving is enabled. To save older messages and additional data, use the backup feature.
Prerequisites
Access to the Kerio Connect Administration
Diagnosis
The types of messages that can be archived are:
Message type | Description |
Local messages |
Messages sent by a local sender to local recipient |
Incoming messages |
Messages sent by a remote sender to a local recipient |
Outgoing messages |
Messages sent by a local sender to a remote recipient |
Relayed messages |
Messages sent by a remote sender to remote recipient |
Please note that per-user archiving is not supported in Kerio Connect. This has been raised as a feature request to our product management team. If you need to perform per-user archiving, for the time being, you would need to employ a software specialized for archiving, like GFI Archiver.
Solution
Archiving the whole server
- In the administration interface, go to Configuration > Archiving and Backup > Archiving.
- Check Enable email archiving.
- To send the archive files to an email address, check Archive to the remote email address and key-in the address.
Note: Folder classification is not maintained when emails are sent to this remote address, all emails from all folders are sent to the Inbox. Other folders such as Sent will be empty. - To save the archive files to a local hard drive, check Archive to the local sub-folder, select the archiving interval, and specify the folder at the Target archive directory at the top.
- Check the types of messages you want to archive- local, incoming, outgoing, or relayed.
- To avoid the anti-spam and antivirus checks before archiving, check Archive messages before applying the content filter check.
- Click Apply to save your settings.
- Restart Kerio Connect if you have changed the archive folder.
Archiving Individual Domains
Note: This information is designed for Kerio Connect 9.1
- In the administration interface, go to Configuration > Archiving and Backup > Archiving.
- Select Enable additional archiving to a remote email address for domains.
- Click Apply.
- Go to Configuration > Domains.
- Double-click the domain you want to archive and go to the Archiving tab.
- Select Archive to the remote email address and key-in the email address.
- Select the types of messages you want to archive - incoming, outgoing, or both.
Note: You cannot archive relayed messages for individual domains. If you want to also archive relayed messages, you need to proceed with Archiving the whole server, as indicated above. - To avoid the anti-spam and antivirus checks before archiving, check Archive messages before applying the content filter check.
- Click OK.
NOTE: Archiving to network drives is not supported.
Assigning administrator rights to view archive folders
By default, only the administrator of the primary domain can view archive folders. However, they can also assign rights to other users.
NOTE: Because all users' messages are archived, only trusted users should have access to the archive folders.
- In the administration interface, go to Accounts > Users.
- Double-click a trusted user and go to the Rights tab.
- Select the Archive folders option.
- Click OK.
Viewing archive folders
Whenever an archive folder is available to be viewed, it is automatically displayed in the Kerio Connect Client of users with appropriate access rights.