Overview
The backup for Kerio Connect installed on macOS keeps failing with such error logs:
OZipFile.cpp: BACKUP: Insufficient space on backup disk (752 MB), minimal free disk space required for backup is 2560 MB.
backup.cpp: Cannot create next volume for backup ZIP file /Volumes/MAIL-BACKUP/KERIO/F20200722T050004Z
backup.cpp: BACKUP: Backup failed in folder ~username@kerio_domain.com/Deleted Items, 752 MB (752 total) of 238552 MB free on destination disk
However, the macOS machine has plenty of disk space left on the external drive.
Prerequisites
- Administrator (root) access to the Kerio Connect server
- Access to the Kerio Connect Administration
Diagnosis
At some point in the past, the backup volume was disconnected, leading the system to create a false mount point for the backup volume — i.e. a false backup disk which is, in fact, a folder in the system volume. Thus, the system volume became full and when Kerio Connect attempts to back up, it fails. All the while, the real backup disk has plenty of space.
The output of df -h command confirms the false mount point issue:
#######################################################################
Filesystem Size Used Avail Capacity %iused Mounted on
/dev/disk0s2 233G 224G 8.3G 97% 96% /
devfs 184K 184K 0B 100% 100% /dev
/dev/disk2s1 1.4T 199G 1.2T 15% 14% /Volumes/MAIL-BACKUP 1
/dev/disk1s2 978G 367G 611G 38% 38% /Volumes/DATA
map -hosts 0B 0B 0B 100% 100% /net
map auto_home 0B 0B 0B 100% 100% /home
Solution
- Open the macOS Disk Utility application and locate the necessary drive.
- Unmount the drive.
- Mount the drive again.
- Open Terminal app, navigate to Volumes (
cd Volumes
) and runls -l
command to display the list of mounting points: - Copy the necessary backup files to the Kerio Connect backup folder.
- In Kerio Connect Administration open Configuration -> Archiving and Backup -> Backup tab -> make sure to select the correct folder.
Confirmation
The backup operation completes successfully.