Overview
Using Exchange accounts in macOS Apple Mail and Outlook clients may impact the Kerio Connect server performance. The accounts may become slow and experience problems with sending and receiving emails.
Upon reviewing the System Health information, there is a noticeable CPU increase (blue line below) after Mac clients are connected to the Kerio Connect server.
Diagnosis
Exchange Webservices accounts, so-called EWS, are using an extensive amount of HTTP/HTTPS connections while performing initial account sync. The synchronization is pulling all the items from the Kerio Connect server, which may cause CPU and RAM to increase.
The normal connection number for Outlook for Mac and Apple Mail EWS accounts is less than 10. The Active Connections tab will show mostly GetFolder and SyncFolderItems operation requests.
For the Apple Mail, the requests will contain /EWS/Exchange.asmx standard configuration URL.
If the number of active connections is not decreasing after the initial sync, you may try re-configuring the EWS accounts on the Mac clients.
Solution
- Remove the Exchange accounts from Mail or Outlook. See instructions for Apple Mail and Outlook for Mac.
- Check if the affected accounts' folders are under the folder item limit of 10.000 items per folder. Very large mailboxes may have corrupted
index.fld
files, which cause CPU overload. Please review Slow Folder Performance issues for more information. - Re-index the accounts' mailboxes: follow the steps from the article Re-Indexing Corrupted User Folders Manually.
- Re-configure the accounts on the email clients. Here are instructions for Adding Exchange Accounts on macOS and for Configuring Exchange Web Services on Outlook for Mac.
- Follow the steps for Outlook profile crashes, gives errors, and does not synchronize all emails; these apply as well for Outlook for Mac
Confirmation
The system resources are getting back to a normal state, the amount of EWS connections decreased.