Overview
While using the Kerio Outlook Connector, the user may receive a Failed Synchronization notice. Such internal mail might be generated both for usual email correspondence and for the Calendar element, so-called appointment or event. The error mail will contain the corrupted .eml
file as an attachment and it might be exceeding several MBs size. It also highlights the source of the problem, i.e. corrupted appointment or email.
Failed notice generates the creation of a specific user folder on the Kerio Connect server-side with the following path
<store_folder>/mail/<domain>/<username>/__keriomapi__STORE/Failed_Conversions
Diagnosis
Failed_Conversions directory is being used for storing the conversions' failures between different types, for example, Mime to MAPI, RTF to MAPI, Unicode to RTF, etc. In case the synchronization of the message from the server to the client fails, the Outlook client receives a detailed report stating the error number. Information about failed sync items is stored on the server in __keriomapi__STORE/Failed_Conversions/#msgs directory. Messages that the client could not sync to the server are stored in the Local Failures folder. These messages can be exported from Outlook in .msg format. For more information, please refer to the 3rd-party article about Saving Outlook message in MSG/EML format.
Solution
In both cases, please wrap the relevant message in the archive (ZIP format) and send it to the Kerio Connect Support. Additionally, include KOFF debug logs.
Then the corrupted .eml files can be deleted from your Kerio Connect server or Kerio Outlook Connector profile.
If you face any further synchronization issues, please consider recreating the Outlook user profile.