Overview
You boot the Kerio Connect VMware Virtual Appliance and see the text "Kerio Connect Engine is starting up...", but even after some time, Kerio Connect doesn't actually start:
This article provides a solution to resolve this.
Prerequisites
Root access to the machine where Kerio Connect is deployed
Diagnosis
The kerio-connect-console service is running but the kerio-connect service is inactive and disabled.
This causes the Kerio Connect server to stay in a hung/stopped state.
Solution
- Login or SSH into the Kerio Connect console on the VMware Virtual Appliance.
- Start the kerio-connect service with the command
service kerio-connect start
The Kerio Connect will now be back to the normal state and you will be able to send and receive emails.
This behavior of not being able to start after a boot/reboot happens when the kerio-connect service is not configured to start automatically after a boot/reboot. To configure it to start automatically on a boot/reboot, run the command systemctl enable kerio-connect.service
on the Kerio Connect appliance:
Confirmation
After the next boot/reboot of the Kerio Connect Virtual Appliance, the kerio-connect service will start automatically and no manual intervention will be required. This can also be verified by running the command service kerio-connect status
and the status will come up as active: