Start a conversation

User quota is displayed incorrectly in Webadmin

Overview

When the storage usage limit is set to a certain value, the user storage quota might be displayed incorrectly.

users_quota.jpg

In such cases, it may prevent users from receiving or sending emails. As a result, the messages are stuck in the message queue with 4.2.2 User quota exceeded status.

message_queue.jpg

Some other user values may be affected, like Last Login date in the past, which could affect reporting and the below steps are applicable for any incorrect stat report of a user.

Prerequisites

Administrator (root) access to the Kerio Connect server.

Diagnosis

Due to environmental issues such as unexpected server crash, storage I/O error, etc, the internal Kerio Connect files may become corrupted. The size of the user's data is stored in the stats.usr (unique per-user) and status.fld (unique per-folder) files.

After files' modification, the user mailbox should be re-indexed. The recommended way is to reindex the mailbox from Webadmin. An alternative is to reindex user folders manually.

Solution

Stats.usr deletion

  1. Stop Kerio Connect.
  2. Navigate to the user store folder. Defaults are:
    1. Windows: C:\Program Files\Kerio\MailServer\store\mail\domain\username
    2. Linux: /opt/kerio/mailserver/store/mail/domain/username 
    3. macOS: /usr/local/kerio/mailserver/store/mail/domain/username
  3. Delete 'stats.usr' from the user root folder.
    stats_usr.png
    For Linux/macOS installations, you can use rm stats.usr​ command
  4. Start Kerio Connect.
  5. Wait for the stats to be populated.
  6. Re-index user mailbox as instructed in the Diagnosis.

This will rebuild the 

Status.fld modification

Note: this method should be used only when the stats.usr deletion didn't help.

  1. Stop Kerio Connect.
  2. Edit 'status.fld', this can be opened in any standard text editor. There is a 'status.fld' in every folder and sub-folder for each user.
  3. Locate the variable 'Sxxxxx' This is the size of this folder in bytes. You can remove this variable, DO NOT alter any other variables.
    status_fld_size.png
  4. Save the file.
  5. Start Kerio Connect.
  6. Wait for the stats to be populated.
  7. Re-index user mailbox as instructed in the Diagnosis.

Confirmation

The user storage usage is shown correctly and the user can send/receive emails.

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted
  3. Updated

Comments