Overview
Koff authentication using a secure connection to the Kerio Connect server is failing after server migration. Both the Kerio Connect and the client computer signs in using ActiveDirectory. When configuring the control panel mail settings and the secure authentication option is selected, the authentication fails where the user information used to authenticate is missing.
The following error appears when trying to connect to the server:
Checking of connection to Kerio Connect failed.
Kerio Outlook Connector is not connected to Kerio Connect.
(For technical support: 0x80042004, Unknown error.)
Upon checking the logs, the following errors are recorded:
Can't bind to LDAP server <server>. simple bind failed. User name: uid=<username>. Err. code: -1
Root Cause
The active directory email account used to authenticate is incorrect.
Resolution
This issue can be resolved by applying the correct configuration. To use secure authentication, check all your settings, and make sure the following requirements are met:
- Kerio Connect must be installed on a computer that is mapped to an active directory server.
- The active directory should be configured on the Kerio connect server. For guidance, refer to the article Connecting Kerio Connect to Directory Services.
- The client windows pc using Koff should be domain mapped.
- The user on the client pc should log in using active directory account having a Kerio connect email address. Creating such an account can be done by installing Kerio connect active directory extension on the active directory server before creating this account.
<supportagent>
Refer to the below JIRA ticket where a video has been shared showing how the settings must be configured as tried and tested by Engineering Team.
</supportagent>
Priyanka Bhotika
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