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Android devices cannot connect via EAS

Overview

While trying to configure the Kerio Connect Exchange account on Android devices, users are receiving the following error:

Something went wrong. Try again later, or contact your IT admin. Email security is not guaranteed.

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The EAS connection problem is limited only for Android users, Apple devices are not affected. The device factory reset was already tried with no success.

Diagnosis

Recent Android versions (8 and up) require a valid SSL certificate to be configured on Kerio Connect server-side. The certificate can also be imported using standard Android settings.

Solution

  1. In the Exchange account configuration screen, click Select under Client certificate field. Click Install certificate.
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  2. Open Google Chrome browser -> Webmail -> Integration with device -> SSL certificate.
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  3. Allow Chrome storage access.
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  4. Click on the downloaded server.cer file.
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  5. Specify a certificate name to the SSL certificate.
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  6. Return back to Exchange account settings -> select the certificate from Downloads.
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  7. Make sure the server settings are correct.
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  8. Allow application access to this phone.
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Confirmation

The account is configured correctly in the Android device.

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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