Overview
This article provides guidance on how to resolve errors when sending emails to the "icloud.com" domain.
[16/Jul/2019 14:14:47] Message from IP address xxx.xxx.xxx.xxx, sender <xxxx@icloud.com> temporarily rejected: sender domain does not resolve
[16/Jul/2019 14:14:47] Message from IP address xxx.xxx.xxx.xxx, sender <xxxx@icloud.com> temporarily rejected: sender domain does not resolve
The above security log message indicates that the message is temporarily blocked because the sender domain "icloud.com" does not resolve. This means that the domain exists, but the authoritative DNS servers are not responding.
Root Cause
Incorrect DNS/ISP/Firewall configuration led to Email routing problems.
Process
- Enable DNS Resolver in Debug logs.
- Reproduce the issue and gather Debug logs. You will see a similar output:
[16/Jul/2019 14:09:03][123145450741760] {dns} Querying server no. 1, address xxx.xxx.xxx.xxx
[16/Jul/2019 14:09:03][123145450741760] {dns} Got answer
[16/Jul/2019 14:09:03][123145450741760] {dns} Valid answer arrived
[16/Jul/2019 14:09:03][123145450741760] {dns} Could not parse the answer
[16/Jul/2019 14:09:03][123145450741760] {dns} Checking DNS for domain icloud.com - The correct output will be trying to resolve the External IP address, not a local. For example:
[26/Jul/2019 06:48:10][3597] {dns} Searching cache for MX records for host icloud.com
[26/Jul/2019 06:48:10][3597] {dns} Searching DNS for MX records for domain icloud.com
[26/Jul/2019 06:48:10][3597] {dns} Querying server no. 1, address xxx.xxx.xxx.xxx
[26/Jul/2019 06:48:10][3597] {dns} Got answer
[26/Jul/2019 06:48:10][3597] {dns} Valid answer arrived
[26/Jul/2019 06:48:10][3597] {dns} MX record: name=icloud.com exchange=mx6.mail.icloud.com preference=10
[26/Jul/2019 06:48:10][3597] {dns} MX record: name=icloud.com exchange=mx2.mail.icloud.com preference=10
[26/Jul/2019 06:48:10][3597] {dns} MX record: name=icloud.com exchange=mx1.mail.icloud.com preference=10
[26/Jul/2019 06:48:10][3597] {dns} MX record: name=icloud.com exchange=mx3.mail.icloud.com preference=10
[26/Jul/2019 06:48:10][3597] {dns} MX record: name=icloud.com exchange=mx4.mail.icloud.com preference=10
[26/Jul/2019 06:48:10][3597] {dns} MX record: name=icloud.com exchange=mx5.mail.icloud.com preference=10
[26/Jul/2019 06:48:10][3597] {dns} Looking up host mx5.mail.icloud.com in DNS...
[26/Jul/2019 06:48:10][3597] {dns} Searching cache for A records for host mx5.mail.icloud.com
[26/Jul/2019 06:48:10][3597] {dns} Searching DNS for A records for host mx5.mail.icloud.com
[26/Jul/2019 06:48:10][3597] {dns} Querying server no. 1, address xxx.xxx.xxx.xxx
[26/Jul/2019 06:48:10][3597] {dns} Got answer
[26/Jul/2019 06:48:10][3597] {dns} Valid answer arrived - The customer can try to set the MX/DNS records to point to Google's IP addresses (
8.8.8.8
and8.8.4.4
) and then re-test the issue again.
Priyanka Bhotika
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