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"Redirect to address" filter rule is dropping messages

Overview

When having incoming filter rule created with Redirect to address option and Subject containing "Test" text, the email messages are not getting delivered to the desired mailbox.

redirect1.png

When the Send notification option is enabled, the original Mail is being received.

redirect1_1.png

The necessary user mailbox has an additional second email address defined.

redirect0.png

 

Diagnosis

The additional email address (user1test@) already delivers to the primary email address (user1@) and when the mail server tries to effectively redirect it to itself, the email goes into a delivery loop and is never delivered.

Solution

  1. In the Webadmin interface, navigate to Configuration -> Message Filters -> double-click the necessary incoming rule.
  2. Add an extra line to the Filter Rule, which excluded the additional email address (user1test@) from the rule.
    redirect2.png

Confirmation

Now any email sent from the admin@ account, containing the keyword test, is delivered to user1@ without issue (original email was sent to user2@).

redirect3.png

Emails addressed to user1test@ are also delivered to user1@ as the redirect is ignored.

redirect4.png

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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