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Server Error: Your Full-Text Index Is Being Re-Indexed. This Operation Can Take a While

Overview

When using the full-text search feature, and when the reindexing is stuck, searches cannot be performed. The following error is received:

Server Error: Your full text index is being re-indexed. This operation can take a while.

Environment

Kerio Connect version 9.x.x

Requirements

Access to the server files.

Root Cause

The full-text indexing process is stuck.

Resolution

  1. Please check for any errors in the following location: web admin GUI > Configuration > Store directory > Full-text search.

  2. Press on Rebuild Index and check for any error messages.

  3. If the Rebuild Index is greyed out, please toggle the functions off, then on and leave it to reindex.

    • NOTE: This is an operation taking quite some time, as it indexes every email in its integrity, not only the headers.

  4. If there are still issues after the above, please proceed with the below steps:

    1. Stop the Kerio Connect service.

    2. Navigate to the Kerio store folder

      • Windows default: C:\Program Files\Kerio\MailServer\store

      • MacOS default: /usr/local/kerio/mailserver/store

      • Linux default: /opt/kerio/mailserver/store

    3. Delete or move out of the Kerio folder the fulltext folder.

    4. Start the Kerio Connect service and allow for the full-text index to be rebuilt from the beginning, avoiding any errors.

Confirmation

After the full text reindexing is finished (this can be checked at web admin GUI > Configuration > Store directory > Full-text search), the users are able to search.

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  1. Priyanka Bhotika

  2. Posted

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