Start a conversation

Failed to read rights from folder INBOX

Overview

You might experience the following Server error when accessing Kerio Connect Webmail.

Failed to read rights from folder INBOX, internal error.
 

mceclip0.png
 

The error log may show such entries:

  Corrupted folder data were found when trying to open and create folder '~johndoe@kerio.com/INBOX'.

The permissions error might be thrown after an unexpected server crash including an unintended reboot.

 


 

Prerequisites

Admin (root) access to Kerio Connect server

 


 

Diagnosis

The cause of this issue is the corruption of Operating System (OS) level folder rights (occupied by another OS process), which prevents Kerio Connect to access the internal structure files, like the FLD and DBO files.

For Windows OS, it can be verified in the running Services app UI.

services_win.png

For Mac, it's possible to track the processes using Activity Monitor. For more information, please refer to the Activity Monitor User guide.

For Linux, you can use the ps -ef command to show the list of the running processes and respective applications.

 


 

Solution

  1. Stop Kerio Connect.
  2. Navigate to the Kerio Connect store folder.
    Please see below the default store folders for different operating systems. 
    • Windows: C:\Program Files\Kerio\MailServer\Store\Mail\[domain][username]\
    • macOS: /usr/local/kerio/mailserver/store/mail/[domain]/[username]
    • Linux: /opt/kerio/mailserver/store/mail/[domain]/[username]
  3. Rename the INBOX folder to INBOX2.
  4. Start Kerio Connect.
  5. Open the affected Webmail.
  6. Check if the INBOX folder is empty.
  7. Log out from Webmail.
  8. Move (cut and paste) all the EML files from INBOX2/#msgs to INBOX/#msgs.
     
    cut.png
     
  9. Log in to Webadmin.
    Please refer to this article on Accessing the Kerio Connect Administration Console.
  10. Re-index the affected user mailbox.
    Please refer to this article on Fixing Data Consistency Issues.
  11. Log in to Webmail and check if the emails are in the INBOX folder.
  12. Remove the INBOX2 folder.

 

Back to top


 

Testing

Access the Webmail INBOX folder, the email items are loading fine with no issues.

 

Back to top


 

Related Articles

Re-Indexing Corrupted User Folders Manually

 

Back to top


 

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted
  3. Updated

Comments