Start a conversation

Kerio Connect Stuck during Upgrade

Overview

When upgrading Kerio Connect on a Windows server, it doesn't progress and the error seen is Wait while the application is prepared for first use. This article provides the steps to resolve this issue.

 

Prerequisites

Administrator access on the Windows server.

 

Diagnosis

This error can occur when Remote Desktop Services (RDS) have not been enabled on the Windows server.

 

Solution

The steps to resolve this issue are provided below:

  1. Click on the Cancel button on the upgrade window and exit the upgrade.
  2. Login as the Administrator on the Windows machine.
  3. Click the Start button.
  4. In the Search box, type gpedit.msc, and then press Enter.
  5. Select Computer Configuration
  6. Select Administrative Templates.
  7. Select Windows Components.
  8. Select Remote Desktop Services.
  9. Select Remote Desktop Session Host.
  10. Select Application Compatibility
  11. Double-click Turn Off Windows Installer RDS Compatibility, and set it to Enabled
  12. Re-run the Kerio Connect update.

 

Confirmation

Kerio Connect will now update successfully and the updated version can be verified from Kerio Connect's Dashboard:

Updated_Version.png

Choose files or drag and drop files
Was this article helpful?
Yes
No
  1. Priyanka Bhotika

  2. Posted

Comments